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LabVIEW
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Launch LabVIEW and click on Blank VI on the Getting Started 

window. This brings up two windows (gray background - front 

panel, white background - block diagram). 
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Click on the front-panel 

Click on View>Controls Palette 

Click on Express>Numeric 

Controls>Dial 

Move  the cursor to position the 

dial in the front-panel window 

Click to drop it into place 

Type in Sinewave Amplitude 

from keyboard 

Place the cursor on the dial, 

right-click and select Visible 

Items>Digital Display  
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Click on the diagram window 

(Window> 

Show Block Diagram) 

Click on View>Tools Palette 

Return to the front panel  

Place a second dial labeled  

DC Offset and a numeric 

control (upper left-hand 

corner of the numeric 

controls palette) labeled 

Sinewave Frequency on the 

front panel 
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Click on Express>Graph Indicators >Waveform Chart 

Place the waveform chart on the front panel 

Type in the caption Waveform Display on your keyboard 
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Place the cursor on the display icon and click the right mouse 

button to bring up the pop-up menu 

Use the Visible Items>PlotLegend and Visible Items>X Scale 

commands to hide the legend and the x-axis scale  

Use the Position/Size/Select tool to position and resize the 

elements on the control panel  

Use the Operate Value tool to edit the lower and upper y-axis 

values, so that they range from -10 to +20 
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Use the Window>Show Block Diagram command to switch to 

the block diagram window 

Use the View>Functions Palette command to make it visible 

Use the Position/Size/Select tool to position the icons 

Make sure that when you left-click on each box, the nearest 

label is the one indicated as being selected 
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Selecting and positioning function blocks on the block 

diagram  

Addition block:Mathematics>Numeric>Add 

Multiplication block: Mathematics>Numeric>Multiply 

Division block: Mathematics>Numeric>Divide 

Sine function: Mathematics>Elementary & Special 

Functions>Trigonometric 

Functions>Sin 

2 Block: Mathematics>Numeric> 

Math & Scientific Constants>2*Pi 

Wait Icon: Programming>Timing>Wait (ms) 

For Loop: Programming>Structures>For Loop 
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Selecting and positioning function blocks on the block diagram  

Sine function: Mathematics> 

Elementary & Special Functions> 

Trigonometric Functions>Sin 

Wait Icon: Programming>Timing>Wait (ms) 

For Loop: Programming>Structures>For Loop 
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Selecting and positioning function blocks on the block diagram  

Addition block:Mathematics>Numeric>Add …. 
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Position the For Loop at the upper left-hand corner of the diagram window 

Holding the mouse button down, drag the lower right-hand corner to enclose all 

of the other icons except the Waveform Display 



Merni informacioni sistemi 2019 14 

Add constants and wire the diagram  

Right-click on the upper left-hand corner of the for loop, select Create Constant 

from the pop-up menu, and type in 361 



Merni informacioni sistemi 2019 15 

Select the Connect Wire tool from the tools palette 

To make a wire connecting the for-loop index (the box labeled i in the lower left-

hand corner of the for loop) to the divider, click on the for-loop index, move the 

cursor to the upper input of the divide box, and click 

Right-click on the lower input of the divider, select Create>Constant, type in 360 

Use the Connect Wire tool to finish the wiring 
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Front panel - click on the run continuously button 

Adjust the controls and observe the display 

Set the sinewave amplitude to 7, the dc offset to 2, and the 

frequency to 0.01 

Use the XScale >AutoScaleX command 
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Adjust the amplitude and dc offset: 

a)Point to and rotate the dial. 

b)Click on the up or down arrows on the left-hand side of the 

digital indicator under the dial 

c)Place the cursor inside the digital indicator under the dial and 

type in a value, which will become effective when you click in a 

blank region on the front panel outside the indicator 
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• Each time the program is operated, all of the functions inside 

the for-loop structure are carried out 361 times  

with i starting at zero and incrementing by one after each 

iteration up through i = 360 

• The value of i to represent angles in one-degree increments  

• Division by 360 and multiplication by 2π converts these 

angles to radians 

• The angles are then multiplied by frequency f  

• The sine block computes the sine of each angle. Thus, each 

time the for loop is executed, a total of 361 points on f cycles 

of the sine function are calculated 

• The amplitude input from the front panel multiplies the 

sinewave values, and the dc offset is added to each value 
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Each time the for-loop finishes, an array of 361 data points is 

passed to the display.  

Each time you click the run button (not the run continuously 

button), f cycles of the signal will appear on the display 
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Adding the DC and RMS Virtual Instruments 

Place and wire additional graphical-program elements to 

compute the average value of the data and the rms value of the 

ac component 

Add front-panel displays 
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The front-panel meter icon, the Controls Palette and select 

Express>Numeric Indicators>Meter 

Drop the meter icon on the front panel and label 

Two meters are needed 
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Right-click on each meter and use the Visible Items>Digital 

Display command to add the digital display 



Merni informacioni sistemi 2019 23 

The signal needs to be integrated over one cycle  

(from t = 0 to t = T) 

The result of the integration is then divided by the duration T 

Conceptually, T=1, the time increment is 1/360 

Integration block is on the functions menu by clicking on 

Mathematics>Integration & Differentiation >Numeric Int. 
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The integration block is a sub VI 
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The integration algorithm (right-click on the input and use 

the pop-up menu to select Create>Constant>Simpson’s Rule 
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The RMS value of the AC component of the signal 

The DC component is subtracted from the input array 

The result is then connected to both inputs of a multiplier 

The corresponding elements of the arrays are multiplied 

The squares of the values in the input array  

This is integrated (T=1, Δt=1/360) 

The square root is computed 

27 
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LabVIEW MathScript 

Tools>MathScriptWindow 

comments following the % signs 



Sadržaj 

• Literatura 

• Diskretizacija po amplitudi – kvantovanje 

• Predstavljanje brojeva sa fiksnom tačkom 

• Predstavljanje sa pokretnom tačkom 

• Greške zbog odsecanja i zaokruživanja 

• Greška kvantovanja 

• Kvantovanje koeficijenata 

• Procena optimalne dužine reči 
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Literatura 

1. Mechatronic Systems Fundamentals, Rolf 
Isermann, Springer, 2005 

2. Metode i instrumentacija za električna 
merenja, N. Miljković, Elektrotehnički fakultet, 
Univerzitet u Beogradu 

3. Senzori i merenja, Mladen Popović, Zavod za 
udzbenike i nastavna sredstva, Srpsko 
Sarajevo, 2004. 
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Senzori i merni sistemi  

 Senzori i pridruženi merni sistemi obezbeĎuju 

zahtevane merljive (opservabilne) informacije o 

procesu u različitim sistemima 

 Predstavljaju vezu izmeĎu procesa i podsistema 

za procesiranje ili obradu informacija (procesori, 

mikroračunari) 

 Senzori, koji mere neelektrične veličine, 

pretvaraju ih u električni signal 

 Opis: karakteristika mernih podsistema, tipova 

signala i principa merenja 
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Senzori i merni sistemi  
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Merni sistemi  
 Svrha je da „posmatra“ (opservira, prati) i 

kvantifikuje vrednosti fizičkih veličina nekog 

procesa i da izvršava obradu izmerenih podataka 

 Senzor - primarna funkcija je da detektuje merenu 

fizičku veličinu i transformiše je u odgovarajući 

signal 

 Uglavnom se koriste senzori sa električnim 

izlaznim signalom 

 Karakteristike signala senzora zavise od principa 

merenja i karakteristika senzora 

Merni informacioni sistemi 2019 36 



Transdjuseri  

 Transdjuseri (konvertori signala) i pojačavači 

transformišu izlazni električni signal senzora u 

standardizovan električni signal 
(0-20 mA, 4-20 mA, 0-10 V) 

 Ukoliko postoje smetnje na nekoj frekvenciji, 

koristi se filtar kako bi smanjio uticaj 

 Kolo odabiranja i (SH) analogno-digitalni 

konvertor su neophodni za konverziju signala u 

digitalni 

 Dalja digitalna obrada signala u računaru 
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Senzori i merni sistemi  
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Klasifikacija senzora 

 svojstva za klasifikaciju senzora 1: 

 merena veličina 

 tip senzora, princip rada senzora 

 tehnologija izrade senzora 

 tipovi signala i interfejsa 

 polja primene senzora, polja aplikacija primenljivosti 

 osobine 

 klasa kvaliteta 

 cena 

 mehaničke veličine 
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Klasifikacija senzora 

 svojstva za klasifikaciju senzora 2: 

 termodinamičke/toplotne/kalorijske veličine 

 električne veličine 

 hemijske i fizičke veličine 
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Mehaničke veličine 

 Geometrijske veličine  

(pomeraj, ugao, nivo, gradijent) 

 Kinematske veličine  

(brzina, ubrzanje, oscilacija, protok) 

 Veličine mehaničkih naprezanja  

(sila, pritisak, moment) 

 Karakteristike materijala  

(masa, gustina, viskoznost) 

 Akustične veličine  

(brzina zvuka, zvučni pritisak, frekvencija zvuka) 
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Toplotne veličine 

 Temperatura 

(kontaktna temperatura, temperatura zračenja) 
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Električne veličine 

 Promenljive električnog stanja  

(napon, struja, električna snaga) 

 Parametri električnih komponenti  

(otpor, impedansa, kapacitet, induktivnost) 

 Promenljive polja  

(magnetno polje, električno polje) 
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Hemijske i fizičke veličine 

 Koncentracija  

(pH vrednost, vlažnost, toplotna provodljivost) 

 Veličina čestice  

(sadržaj suspendovane materije, sadržaj praha) 

 Vrsta molekula  

(molekuli gasa, molekuli tečnosti molekuli čvrstih 

tela) 

 Optičke veličine  

(intenzitet, talasna dužina, boja) 
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Glavni i sekundarni efekat 

 Pretvaranje neelektričnih veličina u električne zavisi od 

fizičkih ili hemijskih efekata (zakonitosti, akcija i reakcija) 

 Mogu se podeliti u glavne (primarne) i prateće 

(sekundarne) efekte 

 Glavni efekat je odgovoran za generisanje željenog 

mernog signala (električni napon piezoelektričnog 

senzora pritiska) 

 Sekundarni efekti koji utiču na generisanje neželjene 

komponente izmerenog signala su superponirajući efekti 

poremećaja (promena temperature u sredini u kojoj se 

vrši merenje); njihov uticaj treba da ima zanemarljiv 

efekat ili da se smanji odgovarajućim 
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Kririjumi za ocenu senzora  

 statičko ponašanje 

 dinamičko ponašanje 

 klasa kvaliteta, merni opseg 

 kapacitet preopterećenja 

 kompatibilnost sa ostalim pridruženim 

komponentama 

 uticaji na okolinu 

 pouzdanost 
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Statičko ponašanje senzora  

 Statičko ponašanje senzora je opisano statičkom 

karakteristikom senzora 

 Statičko ponašanje definiše osetljivost senzora 

odnos promene električnog izlaznog signala sa 

promenom merene veličine 

 važne osobine senzora su 

 Linearnost 

 Histerezis 

 Ponovljivost  
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Dinamičko ponašanje senzora  

 Dinamičko ponašanje senzora je opisano 

frekvencijskim odzivom senzora ili jednostavnim 

karakterističnim vrednostima u vremenskom 

domenu 

 vremenske konstante ili prelomne učestanosti 

 Dinamika senzora treba da bude prilagoĎena 

procesu i zadatku merenja (dinamici merene 

veličine) 
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Klasa kvaliteta  

 Klasa kvaliteta daje osnovnu ocenu tačnosti senzora 

 Procenat maksimalne greške u odnosu na ceo opseg 

 roba široke potrošnje ne zahteva visoku tačnost  

(2% do 5%) 

 Primene u industriji zahtevaju visoku tačnost  

(0.05% do 1%) 

 Oprema za vrlo precizna merenja, za kalibraciju i 

testiranje, mora da zadovolji veoma stroge zahteve 

 Opseg merenja je opseg u kojem su specifikacije 

senzora zadovoljene 
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Kapacitet preopeterećenja 

 Kapacitet preopeterećenja opisuje opseg u kom 

senzor može da radi bez promena u 

karakteristikama i/ili da ne doĎe do oštećenja 

senzora 

 Tipičan kapacitet preopterećenja je izmeĎu 

200% i 500% 
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Kompatibilnost senzora 

 Kompatibilnost senzora zavisi od tipa izlaznog 

signala 

 Uticaji okruženja (kako se senzor uklapa u 

sredinu u kojoj se vrši merenje) 

 Temperatura 

 Ubrzanje  

 Korozija  

 Kontaminacija  

 Habanje  
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Pouzdanost senzora 

 Pouzdanost senzora je opisana karakterističnim 

parametrima 

 prosečno vreme izmeĎu dva otkaza 

 „mean time between failures“ - MTBF u [h] 

 recipročna vrednost - učestanost otkaza [h-1 ] 
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Tip signala  

 Primenjen principa merenja i pridružen ureĎaj za prenosa 

izmerenog signala i njegovu obradu: 

 amplitudno modulisani signali 

 frekvencijski modulisani signali 

 digitalni signali 

 Amplitudno modulisane signale - proporcionalna 

zavisnost izmedju amplitude signala i merene veličine 

 Frekvencija signala proporcionalna merenoj veličini 

 Digitalni signali kodiraju merenu veličinu koristeći binarnu 

predstavi 
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Tip signala  
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Primeri transdjuserskih 

električnih kola  
 Transdjuseri konvertuju amplitudno modulisani 

signal u drugi odgovarajući električni signal: 

 naponsko-strujni pretvarač (transdjuser ili 

konvertor) sa preciznim otpornikom 

 delitelj napona, delitelj struje 

 otpornički - strujni pretvarač  

 kompenzaciona mreža za mereni napon, struju ili 

otpor (otpornički most) 
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Tip 

 Merni pojačavači povećavaju nivo snage izlaznih signala 

senzora ili generišu standardizovane signale veće snage 

(0-10V, 0 - 20mA) 

 Veća snaga kod izlaznih signala senzora je potrebna kao 

ulaz u druge komponente u mernom lancu 

 transmisione veze, filtar i displej 

 obično se sastoje od operacionih pojačavača - 

napravljenih od otpornika i tranzistora u formi analogno-

integrisanog strujnog kola, strujno ogledalo 

 Operacioni pojačavači imaju veliko pojačanje, koje može 

značajno da varira od starenja i od zavisnosti od 

temperature  
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operacioni pojačavači 

 Dodavanjem negativne povratne sprege,  

pojačanje celog kola zavisi samo od otpornosti u 

negativnoj povratnoj sprezi  kod operacionih pojačavača 

 Merni pojačavači sa negativnom povratnom spregom su 

podeljeni u četiri osnovne grupe: 

 pojačavači napona 

 pojačavači napona sa strujnim izlazom 

 pojačavači struje 

 pojačavači struje sa naponskim izlazom 
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Elektromagnetna kompatibilnost 

 EMC 

 Izvori smetnji imaju širok spektar frekvencija od Hz 

(napajanje šinskih vozila) do nekoliko GHz (radarske 

instalacije) 

 pikovi u (pre)opterećenju električnih potrošača, 

varničenje električnih motora, varijacije u napajanju  

 uticaj meĎusobno bliskih polja 

 greške rukovanja (utrokovanje kratkih spojeva) 

 odgovarajuća izolacija ili korišćenje namotaja za 

smanjenje uticaja u vodovima za napajanje 

 Standardima VDE 0874 i VDE 0871 
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Elektromagnetna kompatibilnost 

 Dovoljan prostor izmeĎu ureĎaja manji nivo šuma 

 Instrumenti i kablovi za napajanje treba da se uvek 

instaliraju odvojeno 

 Korišćenje radio zaštite (metalnog kućišta) 

 Transmisione linije konfigurisane u parove  

 Odgovarajuća veza kućišta i uzemljenja je bitna 

 Smanjenje dužina žica koje povezuju ureĎaje i elemente 

sistema - integrisanje senzora, mernog pojačavača i 

ureĎaja za kondicioniranje (pilagoĎenje) signala u jednu 

jedinicu 
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Elektromagnetna kompatibilnost 

 Korišćenje prenosa signala koje je bezbedno u odnosu 

na uticaje smetnji (korišćenje visokih nivoa signala, 

strujnog signala sa živom nulom 4 – 20 mA, kodirano 

slanje signala sa detekcijom greške) – dalje poboljšava 

EMC 

 Optičkom transmisija signala (koja koristi kablove od 

optičkih vlakana) i korišćenjem principa merenja koji su 

neosetljivi na elektromagnetne uticaje (optički, digitalni) 

daje još bolje rezultate 
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Integrisani i inteligentni senzori 

 Izmereni signal mora da nedvosmisleno odgovara 

stvarnoj fizičkoj veličini 

 kalibraciju svakog senzora pojedinačno tokom 

proizvodnje i smanjuje eventualnu neophodnost 

intervencija na analognom delu senzora 

 ugraĎenih brojača koji lako mere frekvenciju 

 Integrisani senzori za izvršavanje dodatnih funkcija 

 pametni senzori, inteligentni senzori 

 za kompenzaciju neželjenog efekta 

 Auto-kalibraciju  

 algoritmi za detekciju i dijagnostikovanje otkaza 
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multisenzorske tehnologije 

 kombinacijom sličnih ili različitih tipova senzora, sa 

razvojima koji nastaju kroz mikromehaniku 

Merni informacioni sistemi 2019 62 



multisenzorske tehnologije 
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Ova prezentacija je nekomercijalna.  

Slajdovi mogu da sadrže materijale preuzete sa Interneta, 

stručne i naučne graĎe, koji su zaštićeni Zakonom o 

autorskim i srodnim pravima.  

Ova prezentacija se može koristiti samo privremeno 

tokom usmenog izlaganja nastavnika u cilju informisanja i 

upućivanja studenata na dalji stručni, istraživački i naučni 

rad i u druge svrhe se ne sme koristiti –  
Član 44 - Dozvoljeno je bez dozvole autora i bez plaćanja  

autorske naknade za nekomercijalne svrhe nastave:  

(1) javno izvoĎenje ili predstavljanje objavljenih dela  

u obliku neposrednog poučavanja na nastavi;  

- ZAKON O AUTORSKOM I SRODNIM PRAVIMA  

("Sl. glasnik RS", br. 104/2009 i 99/2011) 

Profesor dr Miroslav Lutovac 

mlutovac@viser.edu.rs 
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