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1. Launch LabVIEW
LabVIEW R —

File Operate Tools Help

Ed| abVIEW (

@ Create Project @ Open Existing

Recent Project Templates All Recent Files v

014N

Blank VI SasaStojanovic.vi

Acquiring a Signal.vi

Jovan 1.vi
»+ Find Drivers and Add-ons »+ Community and Support > Welcome to LabVIEW
Connect to devices and expand the "~ Paticipate in the discussion forums or " Leamto use LabVIEW and upgrade
functionality of LabVIEW request technical support. from previous versions

£} LabVIEW News | . L .
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2.5elect File»New to display the New dialog box

D

Operate Tools Help

»+ Find Drivers and 2

Connect to devices and
functionality of LabVIEV!

£ LabVIEW News |

=1 < |

I alN\JIC\AS
New - o IEN
Create New Description
Sl ) ” A
{=, Blank VI
{=], Polymorphic VI =
=1y From Template e
== Frameworks I u
=1 Design Patterns
“&) Master/Slave Design Pattern
“&) Producer/Consumer Design Pattern (Data)
“&) Producer/Consumer Design Pattern (Events)
o J‘Q User Interface Event Handler - &=
“&) Dialog Using Events
L 6‘%523:2:?;?;;':;“hng U.se this template to simulate the generation and
g i display of data.
&) Read and Display
=1y Simulated Note: LabVIEW enables automatic error handling by
T3 Generate and Display default for Vis you create from this template.
&) Load from File and Display
=) Touch Panel
“&3 12" Windows Embedded Standard Landscape Screen
%& 12" Windows Embedded Standard Portrait Screen
%3 15" Windows Embedded Standard Landscape Screen
"gj 15" Windows Embedded Standard Portrait Screen
":Qj 6" Windows Embedded Standard Landscape Screen
J!_gj 6" Windows Embedded Standard Portrait Screen
=1 User V.
) Browse... < >
+ Project

#{) Other Files

3. From the Create New list, select

Add to project

4. OK

Vi»From Template»Tutorial (Getting Started)» Generate and Display



5. block diagram window & front pangl)window

B Generate and Display [GenerateDisplay 1.vi] Front Panel *
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= Generate and Display [GenerateDisplay 1.vi] Block Diagram *

File Edit View Project Operate Tools Window Help
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3
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[1. Configure the Simulate Signal Express VI by double-clicking it.]

" > Waveform Graph
Simulate Signal
sT0P

Sine

stop
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>




click front panel Run button,
click front panel S'I;OP button

E

File Edit View Projes
/ Generate and Display [GenerateDisplay 1.vi] Block Diagr I.)@ ﬁ@T] STOP ‘
dit View PrOJect Operate Tools Window Help
C{) @ - )| || g 9‘» Loul'" . ‘15ptAppI|cat|on Font
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[1. Configure the Simulate Signal Expi i | ‘©} 1 }

Sine ,

,

» »
Simulate Signal
Sine by

Amplitude
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Time )
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Adding a Control to the Front Panel

in the front panel window View»Controls Palette

[

Generate and Display [GenerateDisplay 1.vi] Fror

File Edit Project Operate Tools Window Help

Tools Palette
Quick Drop

Breakpoint Manager
Probe Watch Window
Event Inspector Window
Error List

VI Hierarchy

LabVIEW Class Hierarchy
Browse Relationships
Bookmark Manager

Class Browser

.NET Assemblies in Memory
ActiveX Control Property Browser
Getting Started Window...
Navigation Window

Bl covoiboee |ermEmg

Sine PN
Ctrl+Space
Ctrl+L
»
i i
.0E-2  1.0E-1
Ctrl+Shift+B
Ctrl+Shift+N
>
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Controls
| Q, Search I €, Customize~ |
¥ Modern
- » M
= 4o
Numeric Boolean
> »
[1 9 5
Array, Matrix... List,Table & ...
D g b
4] &
Ring & Enum  Containers
o OA’
QO
Variant & Cl... Decorations
P Silver
P System
P Classic
P Express
P NET & ActiveX

Select a Control...

K

String & Path

Refnum



Click the Numeric Controls icon to display
the Numeric Controls palette

Click the Knob control on the Numeric Controls palette to attach the control
to the cursor, and then add the knob to the front panel

Controls D) Generate and Display [Ge

IQSearch | <) Customize~ | =P I B G ¢ d File Edit View Project Operate Tools Window

R fode - - (> [ @[ ][ 14pt Application Font |~ |3
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File»Save As and save the VI as Acquiring a Signal.vi



Changing a Signal Type

Right-click the Simulate Signal Express VI and select Properties from
the shortcut menu to display the Configure Simulate Signal dialog box

Generate and Display [GenerateDisplay 1.vi] Block Diagram *
’ File Edit View Project Operate Tools Window Help
» < — —
> > | @@ |I-.q|l3’ oe l 15pt Application Font |+ H o ][-unv | |@' H‘-’&"- Search
»
»
» > [1. Configure the Simulate Signal Express V| by double-clicking it.|
Simulate Signal
Sine »en , ‘
. Lol > Waveform Graph
Simulate Sign ~ Help T
Sine Exar 4 I
K 1
: = y = Description and Tip...
: Breakpoint >

Waveform Generation Palette p
Replace »

Open Front Panel

Size To Text
View As Icon

Properties

1. Configure the Simulate Signal Express VI by double-clicking it. 9




Changing a Signal Type

=2 Configure Simulate Signal [Simulate Signal]
Signal Result Preview
Signal type
Sine v
Frequency (Hz) Phase (deg) v
10.1 0 2
=
Amplitude Offset E
1 0
[_] Add noise
Time
Time Stamps
'®) Relative to start of measurement
Timing \_J) Absolute (date and time)

Samples per second (Hz)
1000 ®) Simulate acquisition timing

Number of samples Run as fast as possible

100 [v] Automatic

[ Integer number of cycles

Configure Simulate Signal dialog box

Reset Signal
Reset phase, seed, and time stamps

®) Use continuous generation

Signal Name
[v] Use signal type name

Signal name
Sine

OK Cancel Help
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Changing a Signal Type

B
Signal
Signal type
Sawtooth v
Frequency (Hz) Phase (deg)
10.1 0
Amplitude Offset
1 0
[_] Add noise
Timing

Samples per second (Hz)
1000 ®) Simulate acquisition timing

Number of samples ) Run as fast as possible

100 [v] Automatic

(] Integer number of cycles

Click the OK button to save the current
configuration and close the Configure Simulate
Signal dialog box
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Result Preview
1 -

Amplitude

Time

Time Stamps
®) Relative to start of measurement

) Absolute (date and time)

Reset Signal
) Reset phase, seed, and time stamps

®) Use continuous generation

Signal Name
[.#] Use signal type name
Signal name
Sawtooth
0K Cancel Help
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Changing a Signal Type

Generate and Di=='~+ I amacasaNisalac 4 il Dlaal Ninmenn = “
File Edit View Project Operate Tools Wi &2 Generate and

¥ @l @@ ba @ E File Edit View Project Operate Tools \ R I @

> | @ Nn|| |3 |wala o2 ~

[1. Configure the Simulate Signal Express

[1. Configure the Simulate Signal Expre

»
v
» [i i.mu
: .
»

> »
Simulate Signal

Knob Sa*oth »
=

&

Simulate Signal
Sawtooth  »po==
error out »

»

»error in (no errol

»

»
»
»

Reset Signal

stop

Move the cursor over the down arrows at the bottom of the Simulate Signal
Express VI. The down arrows indicate you can reveal hidden inputs and
outputs by extending the border of the Express VI



Wiring Objects on the Block Diagram

Simulate Signal @i
h
Kisait Sawtoot == | |
; ) e Simulate Signal
‘ ‘}‘"LDL Sawtooth  *H
"E‘ —| »error in (No erro Knob____ ——

L

> Reset Signal

* Reset Signal

On the block diagram, move the cursor over the Knob terminal
Use the Wiring tool to wire objects together on the block diagram.

File»Save to save the VI
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Running a VI, adjust the amplitude of the sawtooth wave, STOP

- Generate aaa=s7erTay - |I° I
File Edit View Project Operate Tool: . - . |
e PWOOIS Window Help ‘
||| @1 » @ '.,)“=-
1= i, [ :

Sawtooth _‘

'10'0_1 [ 1 1 i 1
0.0E+0 2.0E-2 4.0E-2 6.0E-2 8.0E-2 1.0E-1
Time

W !
2- -8
P SRR
/l N
0 10 ’ \

front panel, Run button, Move the cursor over the knob, hold the mouse
button down, and turn the knob to adjust the amplitude of the sawtooth
wave. Click the STOP button, shown below, to stop the VI



Modifying a Signal

B2 Generate and Display [GenerateDisplay 1.vi] Block Diagram * — = .
" File Edit BYCUN Project Operate Tools Window Help
f»

» =
. —E@ Functions Palette

1 7&;"”@' ‘_luj Search A ]"?

ont |~ | (3o~

| Tools Palette
1 Quick Drop Ctrl+Space ang it

Breakpoint Manager

Probe Watch Window

Event Inspector Window

Error List Ctrl+L
oad and Save n Waveform Graph

VI Hierarchy

LabVIEW Class Hierarchy

Browse Relationships »
Bookmark Manager

Class Browser Ctrl+Shift+B
.NET Assemblies in Memory

ActiveX Control Property Browser

Getting Started Window...

Navigation Window Ctrl+Shift+N

Click the wire. Press the <Delete> key to delete this wire
View» Functions Palette



Modifying a Signal

Functions

I Q Search ‘ é% Customize~ I

¥ Programming

¥
(0]

&)

Structures
FFE]

Numeric
b >
>

Comparison

v

3

A
File 1/0
@

v

@9

Synchronizat...

viwvl v v v v w
L4
=]
=
E
o
=
o

Gppphics & S...

1 2
2

Cluster, Clas...

[e]

Dialog & Use...

D

Report Gener...

D@ @Mm][@]e=]|

wwner € and Display [

Tools

ba|G@ o+ | 15pt Applid

//IM Project Operate

[1. Configure the Simulate Signal Express V| by douf

Simulate Signal

Sawtooth »

error out >

ri»

»error in (no errol

»

»
»
»

Reset Signal

Formula

| QS:arch' %Customize' ' i' »

Click the wire. Press the <Delete> key to delete this wire =t=v.
View» Functions Palette, Select the Express palette
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¥ Express Use.
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»
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X1

Input
X1

X3
X4
X5
X6
X7
X8

Label
X1

X2
X3
X4
X5
X6
X7

X8

Modifying a Signal

Configure Formula

Home

©

Pi sqrt
7 8
4 5

1 2
0

More Functions

oK

Clear

exp

Cancel

mod

rem

sin

Cos

tan

-

End
min
max

abs
int

sign

Help

The Configure Formula dialog box appears when you place the Express VI

on the block diagram



Modifying a Signal

-

" |Dialog & User Interface
¥

.'.... »
H-w AT
.
File /0 Waveform  Application ...
(D -
_-.) *.P Q& S Waveform Graph
Synchronizat... Graphics & S... Report Gener... m;:;tzo:gna . EerTiie 'E
[ oy
K
» Measurement |/O not; errorout  » & =
LI § » »
» Instrument /O b
. ?'-? ._J »error in (no &HC'j
P Mathematics F
P Signal Processing
P Data Communication g
» Connectivity » Reset Signal
¥ Express

. Arithmetic &

Formula Scale & Map

Jitx) 1
X [>
Time Domain Numeric
¢ '
Math Boolean e

On the Arithmetic & Comparison palette, select the Formula Express VI,
shown below, and place it on the block diagram between the Simulate
Signal Express VI and the Waveform Graph terminal



Modifying a Signal

B2 Configure Formula

Sawtooth *1(

Label Home Backspace Clear End
Sawtooth
e = log In mod min
pi
3 3 I sqrt log2 exp rem max
X4 X4 7 8 9 / sin abs
X5_|[xs 4 5 6 2 cos int
X6 | X6 1 2 3 - 20 Sgn
X7 X7 0 . E + ( )
X8 X8 i
Mere Functions v
i’ OK Cancel Help
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Modifying a Signal

Generate and Display [GenerateDisplay 1.vi] Block Diagram * =

File Edit View Project Operate Tools Window Help
|4>|‘@ @IEI'-N:I'E’ o3 | 15pt Application Font |~ || 3o+ || 5o~ | |&D || “ag|| >/ Search a, I-

[1. Configure the Simulate Signal Express VI by double-clicking it.|

Simulate Signal

Sawtooth Formula
error out 4 » _ Sawtooth

Result

P error in (no erroi

4

Waveform Graph

r  Amplitude

»error in (no errol

»  Frequency
> Offset
» Phase
» Reset Signal




Modifying a Signal

Generate and Display [GenerateDisplay 1.vi] Block Diagram * =

File Edit View Project Operate Tools Window Help
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[1. Configure the Simulate Signal Express VI by double-clicking it.|

Simulate Signal

Sawtooth Formula
error out 4 » _ Sawtooth

Result

P error in (no erroi

4

Waveform Graph

r  Amplitude

»error in (no errol

»  Frequency
> Offset
» Phase
» Reset Signal




File Edit View Project Operate Tools

Modifying a Signal

Generate and Display [GenerateDisplay 1.vi] Block Diagram *

Window Help
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[1. Configure the Simulate Signal Express VI by double-clicking it.|
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Simulate Signal
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error out
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Formula

Waveform Graph
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»
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Result
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File

Modifying a Signal

Generate and Display [GenerateDisplay 1.vi] Front Panel *

Edit View Project Operate Tools Window Help
'$ @ |:\ II I 14ptApp|lcat|on Font « gD' .::[‘]Ev gv . ‘%v Hp Search
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Sawtooth (Formula Result)
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Customizing a Knob Control

Appearance | Data Type

ate

(@) Enabled
() Disabled
() Disabled & grayed

Needle 1 v

Needle color

Lock at minimum
and maximum

Knob Properties: Knob “

Data Entry | Scale | Display Format | TextLabel « »

Caption

[] visible

Size

Height Width
48 48

Add Delete

(] Show digital display(s)

¥| Show increment/decrement buttons

Show value tip strip

OK Cancel Help
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Customizing a Knob Control

= Knob Properties: Knob “

Appearance | DataType | DataEntry | Scale | Display Format | TextLabel « »

Caption
(] visible
e Size
(@ Enabled - —
() Disabled e’gdst ' t43
(") Disabled & grayed
Needle 1 v Add Delete
Needle color ] Show digital display(s)
Lock at minimum
and maximum v| Show increment/decrement buttons
Ll Show value tip strip

cel Help
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Customizing a Knob Control
- oES

D Generate and Display [GenerateDisplay 1.vi] Front Panel *
File Edit View Project Operate Tools Window Help
3 E AR ET— ]
~

53 @ \:! nll 14pt Application Font |~ || 3o~
Sawtooth (Formula Result)

-100.0- | 1 1 1 1
0.0E+0 2.0E-2 4.0E-2 6.0E-2 8.0E-2 1.0E-1

Time
4 3
\ f,
2- ’ -8
s AN
0 10
STOP
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Customizing a Waveform Graph

L D) Graph Properties: Waveform Graph n

Appearance | Display Format | Plots | Scales | Cursors | Documentation « »

Label Caption
[ visible (] visible
Waveform Graph
Enabled State Size
g Height Width
(") Disabled
216 336

(") Disabled & grayed

[[] Show graph palette
Show plot legend
Auto size to plot names
1 $| Plots shown
[ Show x scroll bar
(] Show scale legend
("] Show cursor legend

Cancel Help
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Customizing a Waveform Graph

& -0 e l
-50.0- " -
=2 Graph Properties: Waveform Graph n

Display Format = Plots

Scales | Cursors | Documentation | DataBinding ¢ |*

Sawtooth (Formula Result)

<

ooth (Formula Result Visible
< Colors
I—] -+ | <none> | o .
——— I—I (=] L ] -] (o] F[L' Llne
S— e B | <]
----- o = B8 O 15
- Ce e |
SRR B
User
OO00OOEOEEEEROOEEROCO
Y-scale History System
Amplitude (Y-Axis) v OROOOO0000O000O0 OmOmRmRDO
X-scale [ | @rasscasseass ...
Time (X-Axis) v
[] Do not use waveform names for plot names
27
OK Cancel Help
—

» Reset Signal
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Shortcuts

Shortcut Function
<Ctrl-R> Runs a VL
<Ctrl-Z> Undoes the last action.
<Ctrl-E> Switches between the block diagram and the front panel
window.
<Ctrl-S> Saves a VL
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Profesor dr Miroslav Lutovac
mlutovac@yviser.edu.rs

Ova prezentacija je nekomercijalna.

Slajdovi mogu da sadrze materijale preuzete sa Interneta,
struCne i naucne grade, koji su zasticeni Zakonom o
autorskim i srodnim pravima.

Ova prezentacija se moze Koristiti samo privremeno
tokom usmenog izlaganja nastavnika u cilju informisanja i
upucivanja studenata na dalji strucni, istrazivacki i naucni

rad i u druge svrhe se ne sme Koristiti —
Clan 44 - Dozvoljeno je bez dozvole autora i bez pla¢anja
autorske naknade za nekomercijalne svrhe nastave:

(1) javno izvodenije ili predstavljanje objavljenih dela

u obliku neposrednog poucavanja na nastavi;

- ZAKON O AUTORSKOM | SRODNIM PRAVIMA

("SI. glasnik RS", br. 104/2009 i 99/2011)
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