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Merni informacioni sistemi  

• Status predmeta: izborni  

• Broj ESPB: 8 

• Cilj predmeta:   
– Osposobljavanje za projektovanje i razvoj mernih 

elektronskih kola i sistema.  

• Ishod predmeta:   
– Sposobnost samostalnog rešavanja problema 

projektovanja mernih elektronskih kola, uređaja i 

sistema. 
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Sadrţaj predmeta 1/3 

 Merenja u prostorno-distribuiranim procesnim sistemima 

 Telemetrija 

 Merni signali, njihova obrada i prenos 

 Osnovna kola za analognu i digitalnu obradu mernih 

signala 

 Programabilnost kao svojstvo mernih ureĎaja 

 Programabilni merni sklopovi, programabilni merni 

instrumenti 

 Programabilni kondicioneri mernih signala 

 Statičke i dinamičke karakteristike, strukturne komponente, 

osnovni tipovi 

 Višefunkcijski programabilni merni instrumenti i sistemi 
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Sadrţaj predmeta 2/3 

 Višefunkcijski programabilni merni instrumenti i sistemi 

 Programabilnost i zakonska metrologija 

 Mikroračunarski merni sistemi 

 Funkcije, arhitektura, način rada i osnovne karakteristike 

 Osnove komunikacija u mernim sistemima 

 Interfejsni sistemi u mernoj tehnici 

 Interfejsi za serijski prenos podataka, interfejsi za paralelni 

prenos podataka 

 Standardi za interfejs programabilnih mernih ureĎaja 

(GPIB-interfejs)  
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Sadrţaj predmeta 3/3  
 Personalni računar kao kontroler mernog sistema 

 SCADA-sistemi 

 Standardi za prenos podataka u sistemima daljinskog 

nadzora i upravljanja 

 Merenje u svrhe obračuna 

 Prikupljanje i lokalna obrada mernih podataka, daljinsko 

merenje, standardi za daljinski prenos mernih podataka u 

svrhe obračuna 

 Zaključna razmatranja 

 Pravci daljeg stručnog usavršavanja 
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Pismeni ispit 40 i usmena odbrana seminarskog rada 40 
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Metode izvoĎenja nastave 
 Nastava je organizovana putem predavanja, auditornih i 

laboratorijskih veţbi   

 Ocena znanja (maksimalni broj poena 100)  

 Aktivnost u toku predavanja 10 

 praktična nastava 10 

 pismeni ispit  40  

 seminarski  40  
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Computer-Based 

Instrumentation Systems 

• Merni sistemi bazirani na računarima 

– Računari imaju nisku cenu u odnosu na 

specijalno projektovano hardversko rešenje 

– Programabilnost 

– Paralelan rad 

– Multijezični sistemi 

8 
Merni informacioni sistemi  



9 

Computer-Based 

Instrumentation Systems 
1. Opisati operacije elemenata computer-based 

instrumentation system-a 

2. Identifikovati vrste grešaka koje mogu da se pojave u 

instrumentacionom sistemu 

3. Izbeću najčešće zamke kao što su uzemljene petlje, 

sprega šumova, opterećenje kod senzora 

4. Odrediti specifikacije elemenata za computer-based 

instrumentation  

5. Naučiti rad sa okruţenjem i virtuelnim instrumentima, na 

primer LabVIEW 

Softverski alati i aplikacije 
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Embedded mikrokompjuter? 
• Visoka cena razvojnih sistema programiranje 

embedded mikro-kompjutera-kontrolera 

• Kada se visoka cena  

• When these high costs are prenese na veliki broj 

jedinica, embedded računar i asemblersko 

programiranje moţe da postane najskuplja stavka 

• Za unikatne instrumentacione i kontrolne sistema, 

embedded računarska rešenja su dugotrajna i 

skupa 

Softverski alati i aplikacije 
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>> LabVIEW 

• Odmah sprena data-acquisition ploča 

• High-level softverski paketi 

• Računar opšte namene moţe da se koristi 

 moţe da se kombinuje za brzo 

projektovanje i izradu sofisticiranih 

instrumentacionih sistema i sistema za 

procesnim upravljanjem 

 posebno pogodno za unikatne sistemes 

Softverski alati i aplikacije 
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mkV sensor

Softverski alati i aplikacije 

Electrical Engineering Principles and 

Applications, Allan R. Hambley, 

Pearson Education 

Računarski baziran DAQ sistem 
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Računarski bazirana instrumentacija 

• Fizički sistem 

• Senzori – fizička pojava (temperatura, ugaona 

brzina, pomeranja, pritisak) proizvodi promene 
(iskazane kao napon, struja, otpornost, 

kapacitivnost, induktivnost) 

• Signalni uređaj (Signal conditioners) 

obezbeĎuje da se pobuda sa senzora 

transformiše u električne promene -  
izlaz senzora ne mora da generiše električni signal 

Softverski alati i aplikacije 
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Signalni ureĎaj 

• Pojačava i filtrira 

• Ulaz u data-acquisition (DAQ) ploču 

• Svaki izlazni signal signalnog ureĎaja se 

šalje na sample-and-hold (S/H) kolo  

koji periodično  

odabira-sempluje-odmerava-uzorkuje signal i 

čuva vrednos (koja se više ne menja) 

Softverski alati i aplikacije 
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Multiplexer + ADC 
• Multiplekser (MUX) povezuje izlaze S/H na 

analogno-digitalni konvertor (converter)  

(A/D, ADC) koji konvertuje vrednost u digitalnu reč 

• Ove reči se učitavaju u računar 

• Sve dalje obrade se rade u računaru pre nego što 

se smeste u memoriju, pošalju dalje ili prikaţe 

rezultat 

Softverski alati i aplikacije 
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Senzori 

• Fizička veličina je ta koja se meri 

• Napon na izlazu senzora srazmeran je tome 

što je izmereno 

• k je konstanta osetljivosti,  

m je izmerena vrednost 

 

 

• Eksitacija u formi konstante 

Softverski alati i aplikacije 

mk sensor V
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Electrical Engineering Principles and Applications,  

Allan R. Hambley, Pearson Education 
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Electrical Engineering Principles and Applications, Allan R. 

Hambley, Pearson Education 
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Model senzora 

21 vvvd 

2

21 vv
vcm




Model senzora povezanog na ulaz pojačavača 
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Sample-and-Hold kolo 

Instrumentacioni pojačavač, diferencijalni signal,  

common-mode rejection ratio (CMRR) 



21 Softverski alati i aplikacije 
Electrical Engineering Principles and Applications,  

Allan R. Hambley, Pearson Education 

current-to-voltage converter 



22 Softverski alati i aplikacije 
Electrical Engineering Principles and Applications,  

Allan R. Hambley, Pearson Education 
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Greške mernih sistema 

• Izvor greške, merna veličina i merni sistem 

• bias greška, sistemska greška, ofset, greška 

skaliranja, nelinearnost, histereyis, drift, 

slučajna greška 

Softverski alati i aplikacije 
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Performanse instrumentacionih 

sistema 
1. Tačnost – maksimalna očekivana razlika u 

amplitudi izmeĎu izmerene veličine i stvarne 

vrednosti 

2. Preciznost – Sposobnost instrumenta da ponovi 

izmerenu veličinu ako je merna veličina 

konstantna 

3. Rezolucija – Najmanja moguća vrednost koja 

moţe da prikaţe razliku izmeĎu izmerenih 

vrednosti 

– Veća rezolucija znači manji onkrement 

Softverski alati i aplikacije 
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Šum 
Šum moţe da bude dodat od električnog 

signala ili elektromagnetnog polja koje stvara 

susedno kolo 

Softverski alati i aplikacije 
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Analog-to-Digital Conversion 

• Sampling Rate – učestanost odabiranja 

• Aliasing – ako je učestanost odabiranja 

niska, mora da se koristi anti-alias filtar 

• Kvantizacioni šum 

Softverski alati i aplikacije 
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LabVIEW 

• Postoje signali sa senzora u odgovarajućem 

formatu 

• Transformisani su u digitalni oblik 

• Učitani su u računar 

• Računar koristi sofisticirane programe da 

izdvoji informaciju koja je interesantna 

• Informacija moţe da bude prikazana ili 

iskorišćena da upravlja fizičkim sistemom 

• Brzo se razvija novi instrument, nisa cena 
Softverski alati i aplikacije 
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Virtuelni vremensko-

frekvencijski analizator vibracija 

• Prvi senzor prikuplja signal vibracije 

• Drugi senzor meri brzinu mašine 

• Instrument treba da odredi amplitudu vibracionog 

signala u odnosu na učestanost i brzinu mašine 

• Instrument treba da prikaţe rpm mašine na x osi i 

učestanost na y osi 

• Koristiti boje da se pokaţe amplituda za svaku 

tačku rpm u frekvencijskoj ravni 

Merni informacioni sistemi  
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Primer iz: 

Electrical Engineering Principles 

& Applications, A. R. Hambley, 

Pearson Education 
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LabVIEW? 
• Namenjen da obraĎuje podatke dobijene od 

senzora koji rade u realnom vremenu 

• Da napravi potpuno virtuelni sistem u kome se 

generišu simulacioni podaci i signali korišćenjem VI 

a zatim analiziraju na isti način kao da su signali i 

podaci realni 

• … istovremeno se uče tehnike programiranja i 

odklanjaju greške virtuelnih instrumenata 

• Čest, ne znamo kakvi će biti rezultati koji se 

dobijaju u realnim sistemima 

Softverski alati i aplikacije 
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LabVIEW? 
• Kada se dobijaju neočekivani rezultati,  

moţda nećemo biti sigurni da virtuelni instrument 

izvršava namenjenu funkciju 

• Preporučuje se da se otklanjaju greške mernog 

sistema u fazi razvoja virtuelnog instrumenta sa 

simuliranim podacima sve dok se ostvare ţeljene 

performanse 

• Zadovoljavajući rezultati se dobijaju sa poznatim 

test slučajem, i tek posle toga moţemo da koristimo 

virtuelni instrument u realnim primenama 

Softverski alati i aplikacije 
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LabVIEW? 
• Nije realno da se u knjigama (udţbenicima-

instrukcijama za rad sa virtuelnim instrumentima) 

obezbedi test primer za senzore, merne ureĎaje, i 

DAQ ploče 

• Mogu se naći samo simulirani podaci 

• LabVIEW obezbeĎuje moćne načine da se 

prikupljaju i analiziraju podaci dobijeni od realnih 

sistema u realnom vremenu 

– Na primer da se odredi srednja vrednost (dc 

komponenta) i varijansa (root-mean-square-rms) 

Softverski alati i aplikacije 
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Electrical Engineering Principles & Applications, 

A.R.Hambley, Pearson Education 
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Electrical Engineering Principles & 

Applications, A.R.Hambley, Pearson 

Education 

Primer za veţbu 
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Electrical Engineering Principles & Applications, 

A.R.Hambley, Pearson Education 

Primer za veţbu 
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LabVIEW

Merni informacioni sistemi  
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Pokreni LabVIEW i klikni na Blank VI u Getting Started prozoru 

Pojavljuju se dva prozora  

1.siva mreţasta pozadina - front panel 

2.bela pozadina - blok dijagram 



Merni informacioni sistemi  39 

Klikne se na front-panel 

Klikne se na  

   View>Controls Palette 

Klikne se na  

  Express>Numeric Controls>Dial 

Pomeri se kursor miša na Dial u 

front-panel prozoru 

Klikne se da se spusti tamo gde 

ţelim  

Kuca se sa tastature  

  Sinewave Amplitude 

Postavi se kursor na Dial, desni-

klick i selektuje  

   Visible Items>Digital Display  
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Klikne se na diagram window 
(Window>Show Block Diagram) 

Klikne se na  
View>Tools Palette 

Vratiti se u front panel  

Drugi dial se označi kao  

DC Offset i numeric control 

(gornji levi ugao numeric 

controls palette) označi se 

Sinewave Frequency na front 

panelu 
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Click on Express>Graph Indicators >Waveform Chart 

Place the waveform chart on the front panel 

Type in the caption Waveform Display on your keyboard 
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Place the cursor on the display icon and click the right mouse 

button to bring up the pop-up menu 

Use the Visible Items>PlotLegend and Visible Items>X Scale 

commands to hide the legend and the x-axis scale  

Use the Position/Size/Select tool to position and resize the 

elements on the control panel  

Use the Operate Value tool to edit the lower and upper y-axis 

values, so that they range from -10 to +20 
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Use the Window>Show Block Diagram command to switch to 

the block diagram window 

Use the View>Functions Palette command to make it visible 

Use the Position/Size/Select tool to position the icons 

Make sure that when you left-click on each box, the nearest 

label is the one indicated as being selected 
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Selecting and positioning function blocks on the block 

diagram  

Addition block:Mathematics>Numeric>Add 

Multiplication block: Mathematics>Numeric>Multiply 

Division block: Mathematics>Numeric>Divide 

Sine function: Mathematics>Elementary & Special 

Functions>Trigonometric 

Functions>Sin 

2 Block: Mathematics>Numeric> 

Math & Scientific Constants>2*Pi 

Wait Icon: Programming>Timing>Wait (ms) 

For Loop: Programming>Structures>For Loop 
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Selecting and positioning function blocks on the block diagram  

Sine function: Mathematics> 

Elementary & Special Functions> 

Trigonometric Functions>Sin 

Wait Icon: Programming>Timing>Wait (ms) 

For Loop: Programming>Structures>For Loop 
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Selecting and positioning function blocks on the block diagram  

Addition block:Mathematics>Numeric>Add …. 
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Position the For Loop at the upper left-hand corner of the diagram window 

Holding the mouse button down, drag the lower right-hand corner to enclose all 

of the other icons except the Waveform Display 
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Add constants and wire the diagram  

Right-click on the upper left-hand corner of the for loop, select Create Constant 

from the pop-up menu, and type in 361 
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Select the Connect Wire tool from the tools palette 

To make a wire connecting the for-loop index (the box labeled i in the lower left-

hand corner of the for loop) to the divider, click on the for-loop index, move the 

cursor to the upper input of the divide box, and click 

Right-click on the lower input of the divider, select Create>Constant, type in 360 

Use the Connect Wire tool to finish the wiring 
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Front panel - click on the run continuously button 

Adjust the controls and observe the display 

Set the sinewave amplitude to 7, the dc offset to 2, and the 

frequency to 0.01 

Use the XScale >AutoScaleX command 
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Adjust the amplitude and dc offset: 

a)Point to and rotate the dial. 

b)Click on the up or down arrows on the left-hand side of the 

digital indicator under the dial 

c)Place the cursor inside the digital indicator under the dial and 

type in a value, which will become effective when you click in a 

blank region on the front panel outside the indicator 
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• Each time the program is operated, all of the functions inside 

the for-loop structure are carried out 361 times  

with i starting at zero and incrementing by one after each 

iteration up through i = 360 

• The value of i to represent angles in one-degree increments  

• Division by 360 and multiplication by 2π converts these 

angles to radians 

• The angles are then multiplied by frequency f  

• The sine block computes the sine of each angle. Thus, each 

time the for loop is executed, a total of 361 points on f cycles 

of the sine function are calculated 

• The amplitude input from the front panel multiplies the 

sinewave values, and the dc offset is added to each value 
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Each time the for-loop finishes, an array of 361 data points is 

passed to the display.  

Each time you click the run button (not the run continuously 

button), f cycles of the signal will appear on the display 
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Adding the DC and RMS Virtual Instruments 

Place and wire additional graphical-program elements to 

compute the average value of the data and the rms value of the 

ac component 

Add front-panel displays 



T
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T
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dc d)(
1
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The front-panel meter icon, the Controls Palette and select 

Express>Numeric Indicators>Meter 

Drop the meter icon on the front panel and label 

Two meters are needed 
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Right-click on each meter and use the Visible Items>Digital 

Display command to add the digital display 
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The signal needs to be integrated over one cycle  

(from t = 0 to t = T) 

The result of the integration is then divided by the duration T 

Conceptually, T=1, the time increment is 1/360 

Integration block is on the functions menu by clicking on 

Mathematics>Integration & Differentiation >Numeric Int. 
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The integration block is a sub VI,  

which is the graphical-language equivalent of a subroutine 

Double-click on integration block to see internal structure 

The integrator inputs are the array to be integrated 

The integration algorithm (right-click on the input and use 

the pop-up menu to select Create>Constant>Simpson’s Rule), 

and the time interval between samples 
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The integration block is a sub VI 
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The integration algorithm (right-click on the input and use 

the pop-up menu to select Create>Constant>Simpson’s Rule 
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The RMS value of the AC component of the signal 

The DC component is subtracted from the input array 

The result is then connected to both inputs of a multiplier 

The corresponding elements of the arrays are multiplied 

The squares of the values in the input array  

This is integrated (T=1, Δt=1/360) 

The square root is computed 
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LabVIEW MathScript 

Tools>MathScriptWindow 

comments following the % signs 



Ova prezentacija je nekomercijalna.  

Slajdovi mogu da sadrţe materijale preuzete sa Interneta, 

stručne i naučne graĎe, koji su zaštićeni Zakonom o 

autorskim i srodnim pravima.  

Ova prezentacija se moţe koristiti samo privremeno 

tokom usmenog izlaganja nastavnika u cilju informisanja i 

upućivanja studenata na dalji stručni, istraţivački i naučni 

rad i u druge svrhe se ne sme koristiti –  
Član 44 - Dozvoljeno je bez dozvole autora i bez plaćanja  

autorske naknade za nekomercijalne svrhe nastave:  

(1) javno izvoĎenje ili predstavljanje objavljenih dela  

u obliku neposrednog poučavanja na nastavi;  

- ZAKON O AUTORSKOM I SRODNIM PRAVIMA  

("Sl. glasnik RS", br. 104/2009 i 99/2011) 

Profesor dr Miroslav Lutovac 

mlutovac@viser.edu.rs 
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